File Menu and ToolBar
Replace Pioneer - text/binary/web file - Batch search,replace,convert,rename,split,download    Misc_...  Edit_Menu 

 

File Menu containing "Load" and "Save As", which can be open from "File" menu:

 

 

 

or "popup menu" in edit window:

 

 

 

File ToolBar:

 

 

 

1. File Load(Main Menu/Popup Menu/Toolbar):

 

> Load file to page --> will load file and overwrite all text in current active page

 

>> Append file to page --> will append the file to the bottom of the page

 

>>> Columon Append file to page --> will append the file to the right of the page

 

User can set "output file delimiter" here as column delimiter:

 

 

 

} HEX Load to page --> file will be open and convert to HEX text format

 

 

To learn more about write mode, see Write Mode(Overwrite,Append,Column Append)

 

Dos Command output --> user enter a dos command, the output will be written to the page, user can select working directory and write mode here.

 

 

Note 1: No output will put to the page if DOS commands fail.

 

Note 2: If user want to input more commands in one line, user should join the commands with '&'.

 

WWW Page --> user enter a web link, the content of web will be written to the page, user can select type and write mode.

 

 

There are 3 types to select:

 

text: show web page as pure text

 

html: show web page with html format text

 

links: show all links list of the web page

 

User can also set proxy url, username and password, and timeout for reading web page in "Settings" dialog.

 

Text Generator --> user can generate lines of text by make_batch, make_batch1 function, or self defined function and statement.

 

 

By changing "Text=>" entry, Repeat Times, and ${batch_no*} rules, user can get lines of text with desired format and sequence no.

 

 

 

By writing self-defined string expressions under "Commands" entry, user can get desired output text.

 

User can also select pre-defined "Commands" from list, and make slight change to fit requirement.

 

 

Please refer to Functions part for detail about make_batch and make_batch1 functions.

 

 

2. File Save As(Main Menu/Popup Menu/Toolbar):

 

> Overwrite file --> will save current page and overwrite the file

 

>> Append to file --> will append current page to the bottom of the file

 

>>> Column Append to file --> Will append current page to the right of the file

 

User can set "output file delimiter" here as column delimiter:

 

 

 

} HEX Save to file --> will convert HEX text to byte and save to file

 

 

< Save to files -- Split by bytes/chars/lines/files--> Will split current page to number of bytes/chars/lines/files. The number and bytes/chars/lines/files switches can be set at Settings->Settings menu.

 

User can set "split naming" rule and number of "bytes/chars/lines/files" here:

 

 

<< Save to files -- Split by Paragraph--> Will split current page into many paragraphs, and save each paragraph into a file

 

User can set "split naming" rule and paragraph delimiter here:

 

 

<<< Save to files -- Split by Column--> Will split current page into many columns, and save each column into a file

 

User can set "split naming" rule and column delimiter here:

 

 

 

For detail about file spliting, refer to Spliting output text into multi-files(Horizontal and Vertical).

 

 

3. Clear Page/Clear All Pages(Main Menu/Popup Menu/Toolbar):

 

Clear Page will clear current active page

 

Clear all pages will clear all pages

 

Notes 1: Please save your text manually before clearing, this operation can not "Undo".

 

Notes 2: For large amount of text, "Clear Page" is much more efficient than "Select All" and "Delete".

 

4. Recent File List:

 

By default, system will keep the maximum 10 recently opened file name(manually or automatcially opened).

 

By clicking "File->Recent File List->Settings" menu, user can enable/disable Recent File List generating, as well as clearing existing Recent File List

 

 

 

5. Exit:

 

Quit system, and save current system settings.

 

By default, system will pop up a dialogue for confirmation on quit.

 

User can check option of "Disable quit prompt" on quit dialogue to avoid this window appear next time.

 

 

User can enable it again at Help->Quick Start Guide menu.

 

 




Keywords:

username  proxy  timeout  switch  password  types  requirement  fail  about  overwrite  paragraph delimiter  paragraphs  pop  pass  written  commands  dos command  dos  current  mode  
Search online help: